Royal Exchange Liverpool Wednesday 3rd May 2023 08:15:00


A maintenance window from one of our fibre providers has resulted in loss of service and has breached the timeframe. We are currently working to try and restore services as quickly as possible

Monitoring services

Services are now restoring.

UPDATE FROM FIBRE PROVIDER 03/05/2023 09.03 - Transmission works continue to over-run which is impacting services. Work is ongoing to restore. Additional hardware has been ordered with ETA of 9.00. 

3rd party engineers are remotely connected to the node working on the issue.

We have not received an update as yet to confirm hardware has arrived on site but we continue to push for this update and will provide further information as soon as we have it.

National fibre provider reporting faulty equipment. New equipment is due to arrive with them on-site at 9am. We will have more information shortly after 9am.